Preferred tv store

Samsung KS8000 doesn't remember settings

Hey Folks,

Thanks so much for posting this incredibly useful info.

I never could figure this out before because the options for DTS and Dolby 5.1 don’t show up unless the content is actually playing!

For those of us with older optical-only receivers, this is the only way to make the audio bearable. Dialogue sounds dreadful with the PCM downmix, and I can’t bring myself to replace an otherwise-functional receiver.

I also have a Samsung KS8000, and while your steps above work beautifully, you can’t “enable” the passthrough setting for both DTS and Dolby Digital 5.1 at the same time.

That is, if I set the KS8000 for DTS passthrough, it will work fine on the title I’m playing and on subsequent titles… until I try to play a DD 5.1 title. Then I have to go back to the menu and select Dolby Digital passthrough, which will work on all DD 5.1 titles until I need to play a DTS title.

This is really a ridiculous oversight on Samsung’s part. The KS8000 can clearly detect whether DD 5.1 or DTS is being received, since it shows it on the passthrough menu when they are playing.

Do you guys have any pull with Samsung to get this fixed in firmware? Honestly you shouldn’t even have to “enable” DTS or DD 5.1; selecting passthrough should be enough.

Thanks!

sort by:
  1. Preview Back to editor Format guide

    The editor uses special characters (aka. markdown).

    To post formatted content follow these rules:

    What you typeWhat it will look like
    *italic text*italic text
    **bold text**bold text
    [link](http://rtings.com)link
    > quoted text
    quoted text
    # header

    header

    - item 1
    - item 2
    - item 3
    • item 1
    • item 2
    • item 3

    * Quotes and lists must be followed by a blank line

    You’re correct - unfortunately on newer Samsung TVs it is necessary to select the correct option for each audio format. This actually used to be automatic on the KS8000, until it was changed with a firmware update. We don’t know why they made this change.

  2. Preview Back to editor Format guide

    The editor uses special characters (aka. markdown).

    To post formatted content follow these rules:

    What you typeWhat it will look like
    *italic text*italic text
    **bold text**bold text
    [link](http://rtings.com)link
    > quoted text
    quoted text
    # header

    header

    - item 1
    - item 2
    - item 3
    • item 1
    • item 2
    • item 3

    * Quotes and lists must be followed by a blank line

    You’re correct - unfortunately on newer Samsung TVs it is necessary to select the correct option for each audio format. This actually used to be automatic on the KS8000, until it was changed with a firmware update. We don’t know why they made this change.

    Thanks! Do you know which version of the firmware broke it? Or when? I’d like to report it to Samsung as a bug.

    Appreciate you guys! I based my purchase on your excellent info.

Preview Back to editor Format guide

The editor uses special characters (aka. markdown).

To post formatted content follow these rules:

What you typeWhat it will look like
*italic text*italic text
**bold text**bold text
[link](http://rtings.com)link
> quoted text
quoted text
# header

header

- item 1
- item 2
- item 3
  • item 1
  • item 2
  • item 3

* Quotes and lists must be followed by a blank line

LOG IN

JOIN RTINGS.com

Be part of the most informed community and take advantage of our advanced tools to find the best product for your needs.
Join our mailing list:

Edit Discussion

Preview Back to editor Format guide

The editor uses special characters (aka. markdown).

To post formatted content follow these rules:

What you typeWhat it will look like
*italic text*italic text
**bold text**bold text
[link](http://rtings.com)link
> quoted text
quoted text
# header

header

- item 1
- item 2
- item 3
  • item 1
  • item 2
  • item 3

* Quotes and lists must be followed by a blank line